HID Origo Service Status

This page provides status information, planned maintenance and Incident history for the HID Origo services. Check back here to view the current status of the services listed below. If you are experiencing an issue not listed here, please contact HID Global Technical Support.

All times listed on this site are in UTC unless otherwise noted.


Thursday 3rd September 2026

Intermittent BLE Connectivity Issues Affecting HID Mobile Access app

Summary

HID is investigating reports of intermittent Bluetooth Low Energy (BLE) communication failures affecting the HID Mobile Access app and HID Origo SDK.

Impact

*HID Mobile Access app and HID Origo SDK.

Update Sep 03 at 03:22 UTC

The issue is observed on iPhone 17 models only which are running iOS 26.6 or later.

Update Sep 03 at 03:26 UTC

HID is actively working to resolve this and will provide updates as new information becomes available.

Update Sep 03 at 03:45 UTC

As an immediate mitigation, rebooting the affected device restores BLE functionality.