HID Origo Service Status
This page provides status information, planned maintenance and Incident history for the HID
Origo services. Check back here to view the current
status of the services listed below. If you are experiencing an issue
not listed here, please contact HID Global Technical Support.
All times listed on this site are in UTC unless otherwise noted.
Monday 26th August 2024
HID Origo Services operating at reduced functionality
Update 14:10
- The services are restored and operational. We are continuing to monitor the situation.
Update 13:28
- We are continuing to investigate the issue.
SUMMARY
- HID Origo Management Portal is currently operating at reduced functionality. We are working to address the issue as soon as possible and will provide updates on an ongoing basis until resolved.
IMPACT
- HID Origo Management Portal: Users may experience issues and/or delays in Invitation Code and Mobile ID management.
- HID Origo Mobile Identities API: Users may experience issues and/or delays in Invitation Code and Mobile ID management. Wallet users not affected.
Environment