HID Origo Service Status

This page provides status information, planned maintenance and Incident history for the HID Origo services. Check back here to view the current status of the services listed below. If you are experiencing an issue not listed here, please contact HID Global Technical Support.

All times listed on this site are in UTC unless otherwise noted.


Tuesday 26th January 2021

HID Origo Services Unavailable

Summary

The HID Origo platform is currently experiencing a service disruption affecting login to the HID Origo Management Portal. We are working to address the issue as soon as possible and will provide updates on an ongoing basis until resolved.

Impact

  • HID Origo Management Portal: Currently unavailable
  • HID Reader Manager Portal
  • HID Origo Mobile Identities API
  • HID Reader Manager - Reader Management Service

Environment

Production | HID Origo Management Portal

Update 16:19 UTC

We are continuing to troubleshoot the issue.

Update 17:22 UTC

The services are restored to normal operations.